:: Home :: FAQ :: Search :: Memberlist :: Usergroups :: Register :: Profile :: Log in to check your private messages :: Log in ::
[docs] [linux] Configure Output Latency

 
       Skale Tracker Forum Index -> Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
st3vie
Skale Administrator


Joined: 13 Nov 2002
Posts: 641
Location: Beverwijk, The Netherlands

Posted: Sun Dec 25, 2005 11:34 pm    Post subject: [docs] [linux] Configure Output Latency

NOTE: this is for v0.81

Linux users had to put up with a static 371ms output latency at the moment, but there is a way around this for now. Not ideal, but good enough for the moment, and hopefully feedback will be useful as well.

here are some steps to configure the output latency to something else than the 371ms:
  • open the SkaleLinux.cfg file in your favorite text editor
  • set MODE = 1
    In Linux, 0 - uses the fixed latency. 1 - uses a configurable latency from the config file)
  • set LATENCY = 20
    This is a value that works fine for me - you can try different values here to see what works best for you
  • save the config file and exit the text editor
  • run Skale.x86 with new settings
    to check if it worked, open the config screen in Skale, and you should see the new latency setting

Feedback is appreciated
Happy tracking!

-st3vie


Last edited by st3vie on Wed Dec 28, 2005 3:27 pm; edited 1 time in total
Back to top
dlp
Skale Clueless


Joined: 28 Dec 2005
Posts: 2
Location: Findlay OH USA

Posted: Wed Dec 28, 2005 3:03 pm    Post subject:

Greetings: Thanks for the tips on improving latency. Alas, it's not working. I followed your instructions and altered SkaleLinux.cfg in the Skale802 directory. I tried it with the # character in and removed, got no joy either way. Any further suggestions ?

Btw, the default value for Mode was 2. What does that signify ?

System is Planet CCRMA RH9 on an 800 MHz AMD cpu.

Dave Phillips
_________________
Linux Sound & Music Software at http://linux-sound.org
Back to top
st3vie
Skale Administrator


Joined: 13 Nov 2002
Posts: 641
Location: Beverwijk, The Netherlands

Posted: Wed Dec 28, 2005 3:13 pm    Post subject:

did you check the new version? With v0.802 it won't work.

-st3vie
Back to top
dlp
Skale Clueless


Joined: 28 Dec 2005
Posts: 2
Location: Findlay OH USA

Posted: Wed Dec 28, 2005 4:29 pm    Post subject:

st3vie wrote:
did you check the new version? With v0.802 it won't work.

-st3vie


Thank you, I downloaded and installed 0.81. Now when I set Mode to 1 and Latency to 20 I receive this error:

Can't init sound. Try with another configuration.

I set Latency to various amounts, got the same error message from Skale.

dp
_________________
Linux Sound & Music Software at http://linux-sound.org
Back to top
st3vie
Skale Administrator


Joined: 13 Nov 2002
Posts: 641
Location: Beverwijk, The Netherlands

Posted: Wed Dec 28, 2005 4:46 pm    Post subject:

hm, strange... does Skale work when you set MODE = 0? It seems it can't init the sound device.
The # at the start of the line is needed. It's doesn't mean a comment here, like in many other scripts.

-st3vie
Back to top
Guest






Posted: Wed Dec 28, 2005 5:04 pm    Post subject:

st3vie wrote:
hm, strange... does Skale work when you set MODE = 0? It seems it can't init the sound device.
The # at the start of the line is needed. It's doesn't mean a comment here, like in many other scripts.

-st3vie


Skale works with MODE=0. I've only tested playback of an XM file but it sounded perfect to my ears.

Thanks for the help. Any other suggestions ? I'll gladly supply any other info you need from me.

dp
Back to top
st3vie
Skale Administrator


Joined: 13 Nov 2002
Posts: 641
Location: Beverwijk, The Netherlands

Posted: Wed Dec 28, 2005 5:27 pm    Post subject:

hm, well... MODE=0 is the setting with the static latency of 371ms. MODE=1 should also be using SDL, but should take the latency from the config file.

Maybe something is missing in LibSDL that prevents it from working correctly.

i'm not at home right now, so i can't check yet.

-st3vie
Back to top
Guest






Posted: Sun Jan 01, 2006 1:09 pm    Post subject:

I'll register here soon, just figured I'd post as well. I'm running Slackware 10.2 on a cel 1.7ghz, 512mb ram, Audiophile 2496. Skale boots fine when MODE is set to 0, but I also get "Can't init sound. Try with another configuration." I am not a coder, but would it be extremely difficult to add JACK support to the linux ver to solve latency issues once and for all? Keep up the good work, the ogg+skm is ingenious, JACK support and possibly a sample record (similar to the one in soundtracker for linux) are about the only two things I could think of that'd make Skale more perfect than it already is
Back to top
hyun
Guest





Posted: Sun Jan 22, 2006 9:37 am    Post subject: MODE=1 not work

MODE=0 works

but
MODE=1

"Can't init sound. Try with another configuration"
Back to top
tGz
Skale Clueless


Joined: 02 Mar 2006
Posts: 2
Location: Virginia, USA

Posted: Thu Mar 02, 2006 12:56 am    Post subject:

I get the exact same error.

I have SDL compiled properly, I am using OSS on a Soundblaster Live.

The fixed latency of 371ms feels more like 150ms. But it'd still be nice to get that number below 50 =]
Back to top
MuoX
Skale Clueless


Joined: 18 Aug 2005
Posts: 5
Location: Trelew, Chubut, Argentina

Posted: Thu Mar 02, 2006 7:38 am    Post subject:

The same here, Mode 1 doesn't work, no matter if I change latency.
_________________
Gentoo GNU/Linux
-Kernel 2.6.15.4 Preempting
-KDE 3.5.1
-SDL 1.2.9
-ALSA/Jack
Back to top
Display posts from previous:   
       Skale Tracker Forum Index -> Documentation, Tips & Tricks All times are GMT + 1 Hour
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group